ZEK Availability issues
Incident Report for
CRIF AG
Resolved
ZEK could solve the issue.
Posted
Jul
17
,
2026
-
10:51
CEST
Update
Further information can be found on the ZEK status page:
https://extranet.zek.ch/
Posted
Jul
16
,
2026
-
10:48
CEST
Investigating
We were informed by ZEK that the service is currently not available for all clients.
Further information can be found on the ZEK status page:
https://extranet.zek.ch/
Posted
Jul
16
,
2026
-
10:18
CEST
This incident affected: ZEK Connection.
×
Subscribe to Incident
Subscribe to updates for
ZEK Availability issues
via . You'll receive .